[Osi] Configure with Mosek is not working -- symbol MSK_openmosek

Stefan Vigerske stefan at vigerske.de
Sun Oct 25 11:26:55 EDT 2009


>>> Configure as follows
>>> ./configure --with-mosek-incdir="/usr/local/mosek/6/tools/platform/linux64x86/h"
>>> --with-mosek-lib="-L/usr/local/mosek/6/tools/platform/linux64x86/bin"
>> You also need to provide some -l flags in --with-mosek-lib, i.e.,
>> --with-mosek-lib wants to have the linker flags to link against Mosek,
>> not only a path where the library resists.
>> Stefan
> Hi Stefan,
> I did not explicitly indicate this in the email, but I've tried several
> different configurations of it, -lapack -lm (also blas). None of those
> worked either, at least not without  --enable-mosek-libcheck=no
> anyway. If I put in the libcheck above, configure succeeds but make
> test fails. Can you suggest which flags to use?

You have to check the name of the mosek library, and then do something like
In this case,
/usr/local/mosek/6/tools/platform/linux64x86/bin/libmosek.{a,so} would
be tried. Please check what files you have in .../bin

> Also, can you point me to some documentation on this? Because configure --help
> doesn't mention Mosek.

You have to call configure --help in the Osi subdirectory.

See also


More information about the Osi mailing list