[Osi] Configure with Mosek is not working -- symbol MSK_openmosek

Vikas Singh csviks at gmail.com
Sun Oct 25 11:18:14 EDT 2009

On Sun, Oct 25, 2009 at 5:34 AM, Stefan Vigerske
<stefan at math.hu-berlin.de> wrote:
> Hi,
>> Configure as follows
>> ./configure --with-mosek-incdir="/usr/local/mosek/6/tools/platform/linux64x86/h"
>> --with-mosek-lib="-L/usr/local/mosek/6/tools/platform/linux64x86/bin"
> You also need to provide some -l flags in --with-mosek-lib, i.e.,
> --with-mosek-lib wants to have the linker flags to link against Mosek,
> not only a path where the library resists.
> Stefan

Hi Stefan,

I did not explicitly indicate this in the email, but I've tried several
different configurations of it, -lapack -lm (also blas). None of those
worked either, at least not without  --enable-mosek-libcheck=no
anyway. If I put in the libcheck above, configure succeeds but make
test fails. Can you suggest which flags to use?

Also, can you point me to some documentation on this? Because configure --help
doesn't mention Mosek.



More information about the Osi mailing list