[Coin-ipopt] Problems with MUMPS

jens.pettersson at se.abb.com jens.pettersson at se.abb.com
Tue Sep 18 04:18:45 EDT 2007

Dear All,
I have downloaded the latest versions (tarball) of Ipopt and version 4.7.3 
of MUMPS. I managed to configure and compile it using MSVC 8.0 and Intel 
Fortran 9.1 using cygwin.
When I run the testproblems with MA27 it works but when I set the linear 
solver flag to mumps it gives some error messages, indicating that i dont 
have MUMPS. As far as I can see, it never tries to call MUMPS but halts in 
the initilization stage. A typical error is the following:

Exception of type: OPTION_INVALID in file 
"c:\Solvers\IpoptDir\Ipopt\src\Common\IpOptionsList.cpp" at line 436:
 Exception message: IPOPT tried to get the value of Option: mumps_pivtol. 
It is not a valid registered option.

EXIT: Invalid option encountered.

*** The problem FAILED!

When I look in the file ipopt_config.h in the catalogue 
C:\Solvers\IpoptDir\build\Ipopt\inc it (the configuration I suppose) has 
set the flag COIN_HAS_MUMPS =1
Is there some other manual changes that needs to be done or what can be 
the problem?

//Jens Pettersson 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.coin-or.org/pipermail/ipopt/attachments/20070918/64c4ae24/attachment.html 

More information about the Coin-ipopt mailing list