[Coin-ipopt] Problems with MUMPS

Andreas Waechter andreasw at watson.ibm.com
Tue Sep 18 08:00:25 EDT 2007

Hi Jens,

This is a strange error.  It seems that some compiled files are out of 
date?  (The dependency check of header files unforunately doesn't work 
with the NSVC compilers...)

Could you please do a 'make distclean', followed by a 'configure' and then 
'make install' again?  If that doesn't help, please open a ticket at the 
Ipopt project's page and attach the config.log file FROM THE Ipopt 
subdirectory (not from the directory in which you run configure).



On Tue, 18 Sep 2007 jens.pettersson at se.abb.com wrote:

> Dear All,
> I have downloaded the latest versions (tarball) of Ipopt and version 4.7.3
> of MUMPS. I managed to configure and compile it using MSVC 8.0 and Intel
> Fortran 9.1 using cygwin.
> When I run the testproblems with MA27 it works but when I set the linear
> solver flag to mumps it gives some error messages, indicating that i dont
> have MUMPS. As far as I can see, it never tries to call MUMPS but halts in
> the initilization stage. A typical error is the following:
> C:\Solvers\IpoptDir\build\Ipopt\test>hs071_cpp
> Exception of type: OPTION_INVALID in file
> "c:\Solvers\IpoptDir\Ipopt\src\Common\IpOptionsList.cpp" at line 436:
> Exception message: IPOPT tried to get the value of Option: mumps_pivtol.
> It is not a valid registered option.
> EXIT: Invalid option encountered.
> *** The problem FAILED!
> When I look in the file ipopt_config.h in the catalogue
> C:\Solvers\IpoptDir\build\Ipopt\inc it (the configuration I suppose) has
> set the flag COIN_HAS_MUMPS =1
> Is there some other manual changes that needs to be done or what can be
> the problem?
> //Jens Pettersson

More information about the Coin-ipopt mailing list