[Coin-ipopt] compiling and installing IPOPT

Andreas Waechter andreasw at watson.ibm.com
Wed Apr 18 11:56:55 EDT 2007

Hi David,

As for the libipopt.a:  By default, 'make install' will generate shared 
libraries (libipopt.so, as you found it in your lib directory).  So, the 
compilation of the Ipopt library actually worked, and that's all fine. 
If for some reason you prefer to generate a static library, you can 
specify --disable-shared as "configure" option.  But before rerunning 
configure, I strongly suggest you do a 'make uninstall' and 'make 
distclean' first.  See also 

As for the missing binary:  Are you sure that the AMPL code has been put 
into the right place and has been compiled?  The AMPL solver executable 
"ipopt" (in bin/) is only compiled if the configure script finds the ASL 
source code.  The best way to check is to go into the ThridParty/ASL 
directory (as subdirectory of the directory where you ran configure) and 
see if there is something compiled in there.  If not. then configure 
didn't find the ASL source code.  The output of configure should also tell 
you (in the midst of too much output) if ASL has been found.

So, I suggest, you do 'make uninstall' and 'make distclean', make sure 
that the ASL code is in the right place, and then rerun configure 
(including the --disable-shared option, if you don't like shared 
libraries).  Scan the configure output (towards the end) to see if it says 
that the ASL source code was found.



On Wed, 18 Apr 2007, David Elixmann wrote:

> Hello,
> I'm trying to compile and install IPOPT on a 64bit SUSE Linux 10.2 
> machine, using the Version 3.2.3. Something is going wrong in the 
> installation, and I have no idea what this could be:
> I downloaded the Lapack, ASL, Blas and HSL packages as described in the 
> installation instructions on the 'coin-or/Ipopt' site, and put them all 
> into the appropriate directories. The configuration script ('./configure 
> --prefix=$IPOPTDIR') says that everything went successfully 
> ("Configuration of Ipopt successful - Main configuration of Ipopt 
> successful").
> The code building ('make') also seems to work okay - there are no error 
> messages, although the console screen is cluttered with what seems to be 
> compiler output.
> However, when I try to compile the program ('make install'), I get 
> neither the IPOPT executable that is supposed to end up in 
> $IPOPTDIR/bin, nor the library file libipopt.a that is supposed to end 
> up in $IPOPTDIR/lib. The other files (ipopt_addlibs_cpp.txt and 
> ipopt_addlibs_f.txt) are there, and seem to be okay. There is a message 
> that says that the libraries have been installed - there is in fact a 
> directory $IPOPTDIR/lib, and it contains the files
> ipopt_addlibs_cpp.txt
> ipopt_addlibs_f.txt
> libipopt.la
> libipopt.so
> libipopt.so.0
> libipopt.so.0.0.0
> but it doesn't have libipopt.a which, according to the installation 
> instructions, should also be there.
> There is also a directory $IPOPTDIR/include, which contains 28 header 
> files.
> There is no directory $IPOPTDIR/bin, which according to the installation 
> instructions should include the IPOPT executable that is needed for 
> Do you know what can cause this? I worked with IPOPT before, but only as 
> an end user, without worrying about compilation and installation issues.
> Many thanks in advance,
> David
> -- 
> "Feel free" - 10 GB Mailbox, 100 FreeSMS/Monat ...
> Jetzt GMX TopMail testen: http://www.gmx.net/de/go/topmail
> _______________________________________________
> Coin-ipopt mailing list
> Coin-ipopt at list.coin-or.org
> http://list.coin-or.org/mailman/listinfo/coin-ipopt

More information about the Coin-ipopt mailing list