[ADOL-C] Debug assertion failed -- Program aborts

john capeman john.capeman at gmail.com
Sun Sep 11 14:44:24 EDT 2011

Hi all,

I am new to ADOL-C. I have recently downloaded and installed it on my PC.
I used MSVC++ 2010 and all the steps described in the documentation and
Readme files to build the packages (both ADOL-C and ColPack).
Both the nosparse and sparse version of ADOLC have been build successfully
(I think).

Then I tried to test some of the examples provided in the
"additional_examples" directory. I am very interested
in calculating sparse Jacobians so I used tried the file
"sparse_jacobian.cpp" in the directory "sparse".

I wanted to try independently, so I created a new project and I copy-pasted
the code from sparse_jacobian.cpp
to the file: "my_sparse_jacobian.cpp" The project name is adolcFinalSparse.

I have successfully built the project. But when I run it the program aborts.
This is what message I get:

Debug Assertion Failed!
Program: ...dio 2010\Projects\adolcFinalSparse\Debug\adolcFinalSparse.exe
File: f:\dd\vctools\crt_bld\self_x86\crt\src\dbgheap.c
Line: 1322
Expression: _CrtIsValidHeapPointer(pUserData)
For information on how your program can cause an assertion .......
Abort -- Retry -- Ignore

The problem arises as soon as the memory for the matrix "rind" is freed for
the first time (i.e., free(rind)).

I suspect that it may be something trivial (e.g., I do not set up something
Any suggestions on how to resolve this issue will be very welcome.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/adol-c/attachments/20110911/6983b2ca/attachment.html>

More information about the ADOL-C mailing list