[ADOL-C] Installing ADOLC-2.2.0

Brad Bell bradbell at seanet.com
Wed Jun 1 09:09:14 EDT 2011

Thanks for your work and investigation into this matter.  I really 
appreciate the suggested configure.ac file.

As of version 20110503 of CppAD, forward mode results that contain Nan 
values are detected and reported (when NDEBUG is not defined), see

I am not sure from the discussion below if the test
passed under your copy of ADOL-C.2.1.2 ?

If 2.1.2 passes this test on your system, it does not have any nan 
results. So the question is why are they different for 2.1.2 than for 2.2.

If 2.1.2 fails this test on your system, it passes on my system and the 
question is why is my system different from yours ?

There is an undocumented debugging feature for creating and running a 
program with just one of the CppAD tests in it. (This facilitates 
running the test in a debugger.) For the test above, you could execute 
the following commands:
     svn checkout https://projects.coin-or.org/svn/CppAD/trunk cppad_trunk
     cd cppad_trunk
     mkdir work
     cd work
     ../configure ADOLC_DIR=AdolcPrefix
     cp example/test_one.sh ../example/test_one.sh
     cd ../example
     ./test_one.sh mul_level_adolc.cpp
where AdolcPrefix is the prefix for the ADOL-C install on the particular 
system. This will create and execute the program test_one.exe with only 
this test in it.

The result of the commands above on my system is:

$ ./test_one.sh mul_level_adolc.cpp
g++ test_one.cpp mul_level_adolc.cpp -o test_one.exe -g -Wall -ansi 
-pedantic-errors -Wshadow -std=c++98 -DCPPAD_ADOLC_EXAMPLES -I.. 
-I/usr/include/boost-1_33_1 -I/home/bradbell/include 
-I/home/bradbel/prefix/adolc/include -L/home/bradbell /prefix/adolc/lib 
mul_level_adolc     OK
Ok:    No memory leak detected
All 2 tests passed.

On 6/1/2011 4:43 AM, Kshitij Kulshreshtha wrote:
> As on 2011-05-08 01:25, Brad Bell did write:
>> The suggestion below worked, but I do not understand. I thought that the
>> autotools were designed so that configure and make commands do not
>> require the autotools to be installed (and do not care what version of
>> the autotools I have installed).
>> The multiple level taping  CppAD/ADOL-C tests that worked with version
>> 2.1.2 of ADOL-C do not work with version 2.2.0. For example, see
>>      http://www.coin-or.org/CppAD/Doc/mul_level_adolc.cpp.xml
>> I had to patch ADOL-C 2.1.2 to get it to compile with the tests (see
>> attached shell script).
> Hello Brad,
> I finally got some respite from things to look at your test not working
> and the patch you had to apply. I am attaching  a patch for configure.ac
> (and assorted build files) in CppAD that should be able to detect ADOL-C
> correctly once ADOL-C-2.2 is compiled and installed. No further patching
> inside ADOL-C should be required.
> With this patch I was able to compile CppAD and the test you mentioned,
> however it aborts with a nan value somewhere. Now unfortunately I don't
> understand CppAD enough to figure out what is happening there. Perhaps
> using the ADOL-C tapedocs to generate a listing of the tape generated by
> this program to see if it is consistent would be an idea?
> _______________________________________________
> ADOL-C mailing list
> ADOL-C at list.coin-or.org
> http://list.coin-or.org/mailman/listinfo/adol-c

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.coin-or.org/pipermail/adol-c/attachments/20110601/69b186ed/attachment.html 

More information about the ADOL-C mailing list