[Ipopt] MPI error using Ipopt‏

max leo correa cordova max-leo-19 at hotmail.com
Tue Oct 20 11:36:00 EDT 2015

Thanks for the hints. It seems that compiling with -lcoinmumps makes that error even when deleting the dummy mpi.h. I have only compiled with 

mpic++ -o prueba MyNLP.cpp prueba.cpp -I/home/max/CoinIpopt/build/include/coin -L/home/max/CoinIpopt/build/lib -lipopt -llapack -ldl -lblas -lgfortran -lm -lquadmath -lcoinhsl -lcoinmetis

 and worked, but the solution time has increased (6x). I have tried to use the ipopt.opt file to use ma57 but the solver is still using ma27.  Is there any chance to use mumps or other solver to get a better performance? If so, which is the most recommendable?? How to use the ipopt.opt file (is that included in the compilation)?? I will appreciate your help.
Thanks in advance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20151020/d66092be/attachment-0001.html>

More information about the Ipopt mailing list