[Ipopt] Problem in installation of IPOPT

Chinmay Rajhans rajhanschinmay2 at gmail.com
Wed Jun 24 15:35:57 EDT 2015

I was trying to install IPOPT on Linux 32 bit OS.

I followed this:

Then I did this:

Configure seems to have worked ok.
There seem some problem when I ran make command.

Mostly, error is related to MUMPS.
Tried downloading this separately and installing.

Kindly let me know what else I can try.

Thank you.


On 24 June 2015 at 15:24, Stefan Vigerske <stefan at math.hu-berlin.de> wrote:

> Hi,
> when did you get this message? I sometimes get this when I try to do a
> make install in the Ipopt subdirectory of my build directory instead of the
> top level of the build directory.
> If that already comes up during configure, then you could also try running
> configure with the option --disable-pkg-config
> That is still sufficient if you want to build Ipopt together with the
> Mumps dependency (as you seem to do).
> Stefan
> On 06/24/2015 10:59 AM, Chinmay Rajhans wrote:
>> To: all,
>> I was trying to install IPOPT toolbox on Linux machine.
>> I am getting this error:
>> Package coinmumps was not found in the pkg-config search path.
>> Perhaps you should add the directory containing `coinmumps.pc'
>> to the PKG_CONFIG_PATH environment variable
>> Package 'coinmumps', required by 'IPOPT', not found
>> I have installed MUMPS, using .get_mumps command and then using configure
>> etc.
>> Kindly let me know what can be wrong.
>> Else, is it possible to run it without mumps.
>> Thank you.
>> Chinmay
>> _______________________________________________
>> Ipopt mailing list
>> Ipopt at list.coin-or.org
>> http://list.coin-or.org/mailman/listinfo/ipopt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20150625/b7c541ed/attachment.html>

More information about the Ipopt mailing list