[Ipopt] Compiling IPOPT with ma57 source code

Senses,Begum bgmsenses at ufl.edu
Tue Jun 17 17:12:32 EDT 2014

Hello everyone,

I am using ipopt with ma57. I can compile ipopt using the flag 
--enable-matlab-ma57. But now I need to compile ipopt with ma57 source 
code. I am aware of the fact that somebody else asked this question 
before (https://projects.coin-or.org/Ipopt/ticket/232) but the answers 
did not solve my problem. Now, I will explain what I did to compile 
ipopt with ma57 source code. First, I put coinhsl into Thirdparty folder 
and used the following configuration script.

./configure --disable-shared CC=gcc --with-blas='-framework vecLib' 
--with-lapack='-framework vecLib' ADD_CXXFLAGS='-stdlib=libstdc++'

This configuration script worked fine. I was also able to run make and 
make install. I even obtained a mexfile. But when I try to run my 
problem from Matlab I got the following error.

Invalid MEX-file
6): Symbol not found: __gfortran_transfer_array_write
   Referenced from:
   Expected in:

I tried to change the FC_LIBDIR line in mexopts.sh from

FC_LIBDIR=`$FC -print-file-name=libgfortran.dylib 2>&1 | sed -n 


FC_LIBDIR=`$FC -print-file-name=libgfortran.a 2>&1 | sed -n 

but it is still giving me the same problem.

I am using mac 0SX 10.8.5, gcc 4.8.2 and XCODE 5.1.1. I know my 
gfortran is too new for matlab mexfile and I am supposed to have 
gfortran 4.2 but I am also working with ma57 separately on this computer 
so I dont want to mess with my gfortran compiler. Is there a way to fix 
my problem without changing gfortran compiler?

Thank you.

Senses, Begum

More information about the Ipopt mailing list