[Ipopt] ipopt make fails

Joris Kinable deus87 at gmail.com
Sat Mar 30 03:14:03 EDT 2013


I'm having some issues with the installation of Ipopt. I have followed
the installation guide
(http://www.coin-or.org/Ipopt/documentation/node22.html) up to the
point where I have to run 'make'. This fails with the following


   use hsl_ma77_double
Fatal Error: Can't open module file 'hsl_ma77_double.mod' for reading
at (1): No such file or directory
make[3]: *** [ma77_iface.lo] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/Ipopt-3.10.0/build/Ipopt/src/Algorithm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/Ipopt-3.10.0/build/Ipopt'
make: *** [all-recursive] Error 1

I have the same error with both ipopt 3.10.0 and 3.10.3 which I
downloaded here: http://www.coin-or.org/download/source/Ipopt/

After downloading Ipopt, I downloaded ASL, Blas, Lapack, Metis, Mumps
using the ./get.XXX commands. Finally, I also downloaded the coinhsl
v2012.12.21 package.
The contents of the package have been placed (according to the
instructions) in: /opt/CoinIpopt/ThirdParty/HSL/coinhsl
Within this folder I ran the commands 'configure' and 'make'. As a
result, the folder /opt/CoinIpopt/ThirdParty/HSL/coinhsl contains the
following files:

aclocal.m4                 hsl_ma77d.o                 hsl_zb01_integer.mod
ChangeLog                  hsl_ma77_double_iface.mod   hsl_zd11_double.mod
CoinHslConfig.h            hsl_ma77_double.mod         INSTALL
CoinHslConfig.h.in <http://coinhslconfig.h.in/>         hsl_ma86
coinhsl.pc                 hsl_ma86d_ciface.lo         libcoinhsl.la
coinhsl.pc.in              hsl_ma86d_ciface.mod        libtool
common                     hsl_ma86d_ciface.o          LICENCE
config.guess               hsl_ma86d.lo                ltmain.sh
config.h                   hsl_ma86d.o                 m4
config.h.in                hsl_ma86_double.mod         ma27
config.log                 hsl_ma97                    ma27d.lo
config.status              hsl_ma97d_ciface.lo         ma27d.o
config.sub                 hsl_ma97d_ciface.o          ma28
configure                  hsl_ma97d.lo                ma28d.lo
configure.ac               hsl_ma97d.o                 ma28d.o
deps90.lo                  hsl_ma97_double_ciface.mod  ma57
deps90.o                   hsl_ma97_double.mod         ma57d.lo
deps.lo                    hsl_mc34_double.mod         ma57d.o
deps.o                     hsl_mc64_double.mod         Makefile
dump.lo                    hsl_mc68                    Makefile.am
dump.o                     hsl_mc68_double.mod         Makefile.in
hsl_kb22_long_integer.mod  hsl_mc68_integer.mod        mc19
hsl_ma54_double.mod        hsl_mc68_single.mod         mc19d.lo
hsl_ma64_double.mod        hsl_mc69_double.mod         mc19d.o
hsl_ma77                   hsl_mc78_integer.mod        missing
hsl_ma77d_ciface.lo        hsl_mc80_double.mod         README
hsl_ma77d_ciface.o         hsl_of01_double.mod         stamp-h1
hsl_ma77d.lo               hsl_of01_integer.mod        stamp-h2

Next I created the folder /opt/CoinIpopt/build. Inside the folder
build, I ran "../configure", "./make". The result is the above error.
Attached to this e-mail you can find the config.log
file which is located in the /opt/CoinIpopt/build folder. Clearly,
inside the /opt/CoinIpopt/ThirdParty/HSL/coinhsl folder, there is the
file 'hsl_ma77_double.mod', so I'm not sure why 'make' is complaining?

Any suggestions what I did wrong? Feel free to ask if you need more


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20130330/d61b8ad8/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.rar
Type: application/rar
Size: 8046 bytes
Desc: not available
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20130330/d61b8ad8/attachment-0001.bin>

More information about the Ipopt mailing list