[Ipopt] ipopt make test fails: missing MA27

Joris Kinable deus87 at gmail.com
Mon Apr 1 06:16:12 EDT 2013

Dear Tony,

Your suggestions worked perfectly! Ipopt now works fine for me under Kubuntu
11.10  (64 bit).

Would it be possible to update the installation manual (I would be willing
to update it myself)?

1. Getting Ipopt via subversion:
This page refers to an outdated version of Ipopt. Perhaps the link on this
page needs to be replaced with: https://projects.coin-or.org/**
svn/Ipopt/trunk <https://projects.coin-or.org/svn/Ipopt/trunk>

2. Downloading the HSL routines:
This page is outdated.

a. The page does not mention that there exists an HSL package for Ipopt
including all the routines. Perhaps refer to this page:
b. Include in the installation instructions that after downloading the
above package, you can simply put the folder under ./ThirdParty/HSL/ and
rename it to coinhsl. Currently, this page contains a rather complex
description of renaming and merging a number of files, which apparently is
no longer required.



On Sat, Mar 30, 2013 at 9:49 AM, Tony Kelman <kelman at berkeley.edu> wrote:

> Joris,
> The issue is because you're using an older version of Ipopt. The latest
> all-in-one "HSL for Ipopt" coinhsl downloads don't work immediately with
> any released version of Ipopt without a few extra steps (detailed in this
> file: https://projects.coin-or.org/**svn/BuildTools/ThirdParty/HSL/**
> releases/1.3.3/INSTALL.HSL<https://projects.coin-or.org/svn/BuildTools/ThirdParty/HSL/releases/1.3.3/INSTALL.HSL>).
> But rather than going through those steps, it's simplest to work with Ipopt
> trunk (https://projects.coin-or.org/**svn/Ipopt/trunk<https://projects.coin-or.org/svn/Ipopt/trunk>)
> for now, which should just work if you put the coinhsl folder in that
> location.
> -Tony
> -----Original Message----- From: Joris Kinable <deus87 at gmail.com>
> Date: Sat, 30 Mar 2013 08:09:21 +0100
> To: ipopt at list.coin-or.org
> Subject: [Ipopt] ipopt make test fails: missing MA27
> Dear,
> I'm having some issues with the installation of Ipopt. I have followed
> the installation guide
> (http://www.coin-or.org/Ipopt/**documentation/node22.html<http://www.coin-or.org/Ipopt/documentation/node22.html>)
> up to the
> point where I have to run 'make test'. This fails with the following
> error:
> ==============================**===
> Running unitTests...
> Testing AMPL Solver Executable...
>    no AMPL solver executable found, skipping test...
> Testing C++ Example...
> ---- 8< ---- Start of test program output ---- 8< ----
> Exception of type: OPTION_INVALID in file
> "../../../../Ipopt/src/**Algorithm/IpAlgBuilder.cpp" at line 297:
> Exception message: Selected linear solver MA27 not available.
> Tried to obtain MA27 from shared library "libhsl.so", but the
> following error occured:
> libhsl.so: cannot open shared object file: No such file or directory
> ==============================**====
> First I have downloaded ipopt from svn:
> svn co https://projects.coin-or.org/**svn/Ipopt/stable/3.9<https://projects.coin-or.org/svn/Ipopt/stable/3.9>CoinIpop
> Next I have have downloaded the 3th party packages, including the following
> package containing MA27: coinhsl v2012.12.21. The contents of the latter
> package have been placed (according
> to the instructions) in: /opt/CoinIpopt/ThirdParty/HSL/**coinhsl
> This folder contains the following files:
> ==============================**====
> aclocal.m4                 hsl_ma77d.o                 hsl_zb01_integer.mod
> ChangeLog                  hsl_ma77_double_iface.mod   hsl_zd11_double.mod
> CoinHslConfig.h            hsl_ma77_double.mod         INSTALL
> CoinHslConfig.h.in         hsl_ma86                    install-sh
> coinhsl.pc                 hsl_ma86d_ciface.lo         libcoinhsl.la
> coinhsl.pc.in              hsl_ma86d_ciface.mod        libtool
> common                     hsl_ma86d_ciface.o          LICENCE
> config.guess               hsl_ma86d.lo                ltmain.sh
> config.h                   hsl_ma86d.o                 m4
> config.h.in                hsl_ma86_double.mod         ma27
> config.log                 hsl_ma97                    ma27d.lo
> config.status              hsl_ma97d_ciface.lo         ma27d.o
> config.sub                 hsl_ma97d_ciface.o          ma28
> configure                  hsl_ma97d.lo                ma28d.lo
> configure.ac               hsl_ma97d.o                 ma28d.o
> deps90.lo                  hsl_ma97_double_ciface.mod  ma57
> deps90.o                   hsl_ma97_double.mod         ma57d.lo
> deps.lo                    hsl_mc34_double.mod         ma57d.o
> deps.o                     hsl_mc64_double.mod         Makefile
> dump.lo                    hsl_mc68                    Makefile.am
> dump.o                     hsl_mc68_double.mod         Makefile.in
> hsl_kb22_long_integer.mod  hsl_mc68_integer.mod        mc19
> hsl_ma54_double.mod        hsl_mc68_single.mod         mc19d.lo
> hsl_ma64_double.mod        hsl_mc69_double.mod         mc19d.o
> hsl_ma77                   hsl_mc78_integer.mod        missing
> hsl_ma77d_ciface.lo        hsl_mc80_double.mod         README
> hsl_ma77d_ciface.o         hsl_of01_double.mod         stamp-h1
> hsl_ma77d.lo               hsl_of01_integer.mod        stamp-h2
> ==============================**============================
> Next I created the folder /opt/CoinIpopt/build. Inside the folder
> build, I ran "../configure", "./make", "./make test". The result is
> the above error. Attached to this e-mail you can find the config.log
> file which is located in the /opt/CoinIpopt/build folder.
> I thought that the problem was that the files inside
> /opt/CoinIpopt/ThirdParty/HSL/**coinhsl were not compiled for some
> reason. So I went to this folder and also ran "../configure",
> "./make", "./make install". The result is that I now have the
> following files inside /usr/local/lib:
> libcoinhsl.a   libcoinhsl.so    libcoinhsl.so.0.0.0
> libcoinhsl.la  libcoinhsl.so.0
> I made sure that the directory /usr/local/lib was set in the variable
> Any suggestions what I did wrong? Feel free to ask if you need more
> information.
> br,
> Joris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20130401/538614f1/attachment-0001.html>

More information about the Ipopt mailing list