[Ipopt] Ipopt compilation on mac OS X 10.6

Ray Zimmerman rz10 at cornell.edu
Mon Jan 30 15:07:09 EST 2012

You may find some help at ...


... though I am using gfortran, not g95.

Ray Zimmerman
Senior Research Associate
419A Warren Hall, Cornell University, Ithaca, NY 14853
phone: (607) 255-9645

On Jan 30, 2012, at 10:49 AM, Sylvain Auliac wrote:

> Hello,
> i'm trying to have ipopt working on my laptop (OS X 10.6), but i have configuration problems. I can compile and create the library files, but I always get some messages like that at runtime :
> dyld: Symbol not found: __g95_filename
>   Referenced from: /Users/auliac/Desktop/Ipopt-3.2.1/lib/libipopt.0.dylib
>   Expected in: flat namespace
> As suggested in the "current issues" section of the site, I have added ADD_FFLAGS="-mmacosx-version-min=10.4" while configuring. If I only do that, I get this error when I type "make test" when tests are run. I have then tried several flags combination from this troubleshooting page, I only have better results when I also add LDFLAGS="-flat_namespace" . With that, the console displays a succes message when I run the test. But still the executable from the exemples folder send this "_g95_filename" error (not to speak about code of my own). This is somewhat weird... I use gcc for c/c++ compilation and g95 for the fortran.
> I'd greatly appreciate any help.
> Sylvain Auliac
> Laboratoire Jacques-Louis Lions
> Université Pierre et Marie Curie
> mail: auliac at ann.jussieu.fr
> tel : 01 44 27 71 70
> _______________________________________________
> Ipopt mailing list
> Ipopt at list.coin-or.org
> http://list.coin-or.org/mailman/listinfo/ipopt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20120130/019af6e5/attachment.html>

More information about the Ipopt mailing list