[Ipopt] Ipopt compilation on mac OS X 10.6

Sylvain Auliac auliac at ann.jussieu.fr
Mon Jan 30 10:49:43 EST 2012

i'm trying to have ipopt working on my laptop (OS X 10.6), but i have configuration problems. I can compile and create the library files, but I always get some messages like that at runtime :

dyld: Symbol not found: __g95_filename
  Referenced from: /Users/auliac/Desktop/Ipopt-3.2.1/lib/libipopt.0.dylib
  Expected in: flat namespace

As suggested in the "current issues" section of the site, I have added ADD_FFLAGS="-mmacosx-version-min=10.4" while configuring. If I only do that, I get this error when I type "make test" when tests are run. I have then tried several flags combination from this troubleshooting page, I only have better results when I also add LDFLAGS="-flat_namespace" . With that, the console displays a succes message when I run the test. But still the executable from the exemples folder send this "_g95_filename" error (not to speak about code of my own). This is somewhat weird... I use gcc for c/c++ compilation and g95 for the fortran.

I'd greatly appreciate any help.

Sylvain Auliac
Laboratoire Jacques-Louis Lions
Université Pierre et Marie Curie
mail: auliac at ann.jussieu.fr
tel : 01 44 27 71 70

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20120130/5d91cb82/attachment.html>

More information about the Ipopt mailing list