[Ipopt] problems with pardiso solver

Ted Rosenbaum ted.rosenbaum at yale.edu
Wed Mar 3 23:01:53 EST 2010

I have been badly struggling to get a working version of ipopt with
pardiso.  (I easily compiled a version with ma27).

Currently, I am compiling with the MKL libraries for blas and lapack, using
the gnu compilers, and using the downloaded version of pardiso. I have tried
intel compilers and the intel pardiso (from mkl), but have ran into a
variety of issues.
With this command:
../configure  ADD_FFFLAGS="-fopenmp -lpthread -lm" ADD_CFLAGS="-fopenmp
-lpthread -lm -lgfortran" ADD_CXXFLAGS="-fopenmp -lpthread -lm -lgfortran"
CXXLIBS="-L/usr/lib/gcc/x86_64-linux-gnu/4.4.1 -lstdc++"
CLIBS="-L/usr/lib/gcc/x86_64-linux-gnu/4.4.1 -lgcc_s"
FFLIBS="-L/usr/lib/gcc/x86_64-linux-gnu/4.4.1 -lgfortran"
ADD_CFLAGS="-fopenmp -lpthread -lm"  --with-lapack="-L$MKLPATH
$MKLPATH/libmkl_solver_ilp64.a -Wl,--start-group -lmkl_gf_ilp64
-lmkl_gnu_thread -lmkl_core -Wl,--end-group -fopenmp -lpthread"
--with-blas="-L$MKLPATH $MKLPATH/libmkl_solver_ilp64.a -Wl,--start-group
-lmkl_intel_ilp64 -lmkl_gnu_thread -lmkl_core -Wl,--end-group -fopenmp
-lpthread" --with-pardiso="-L/home/ted/Binaries -lpardiso400_GNU430_IA64"
--without-ma27 --prefix=/usr/local --enable-debug

I am able to compile everything.  However, when I run "make test" I receive
a segmentation fault on all of the tests.

I am running ubuntu 9.10 64bit.

Thanks for any help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.coin-or.org/pipermail/ipopt/attachments/20100303/6eb5a2e6/attachment.html 

More information about the Ipopt mailing list