[Ipopt] get.Mumps

Brad Bell bradbell at seanet.com
Mon Apr 26 08:56:53 EDT 2010

Reading the documentaiton in
more carefully. I noticed the text:

"You can also try to run the script get.Mumps in 
$IPOPTDIR/ThirdParty/Mumps if you have wget installed in your system. 
The MUMPS version number in that file might be out of date; in that case 
edit the value assigned to the mumps_ver variable at the beginning of 
the script."

In get.Mumps I changed "mumps_ver=4.8.3" to "mumps_ver=4.9.2",
and the get.Mumps command works now.

Now when I run the command
in the Ipopt-3.8.1 directory, I get the error message

Fatal Error: Can't open module file 'tools_common.mod' for reading at (1):
No such file or directory
make[1]: *** [dmumps_part2.lo] Error 1
make[1]: Leaving directory 
make: *** [all-recursive] Error 1

On 4/25/2010 7:38 AM, Brad Bell wrote:
> Using Ipopt-3.8.1.tgz, when I attempt the execute the commands
>       cd ThirdParty/Mumps
>       get.Mumps
> It tries to do a wget on the file
>       http://mumps.enseeiht.fr/MUMPS_4.8.3
> which no longer exists.
> The instructions on
>       http://www.coin-or.org/Ipopt/documentation/node17.html
> suggest that one obtain the source code from
> http://graal.ens-lyon.fr/MUMPS/
> When I try to do that, I get to the form
>     http://graal.ens-lyon.fr/MUMPS/index.php?page=dwnld#form
> when I fill out the form, it informs me that
> "Your request has been registered.  You should receive the package by
> separate e-mail within a few days ..."
> Is there a way to obtain the Mumps solver with out having to fill our a
> form and without having to wait days ?
> _______________________________________________
> Ipopt mailing list
> Ipopt at list.coin-or.org
> http://list.coin-or.org/mailman/listinfo/ipopt

More information about the Ipopt mailing list