[Ipopt] Termination code 11

Andreas Waechter andreasw at watson.ibm.com
Fri May 15 12:24:53 EDT 2009


I don't think that there are any relevant changes from 3.6.0 to 3.6.1 that 
might fix this issue...

termination code 11 means that there is memory bug.  Johan, I suggest you 
get a clean version of Ipopt (well, then you might was well take 3.6.1) 
and all dependencies, and reconfigure the same way as you did before, just 
add "--enable-debug" to the configure command line.  Then do the usual 
make test and make install.

Then see if you still have this problem.  (If not, try again, but without 
--enable-debug.)  If you still have this problem, you need to create an 
AMPL input file (*.nl) so that you can run the Ipopt AMPL solver from the 
command line.  To do that, just add

write gbla;

before the solve command in your AMPL script.  This should create a file 
"bla.nl".  Then try to run

ipopt bla.nl

from the command line, and hopefully you will still see the error.  Now 
you can run Ipopt through a debugger or better, a memory checker, as in

valgrind --db-attach=yes ipopt bla.nl

This will tell you where the memory problem appears.  Maybe you can 
already see then what the problem is.  If you can't please submit a 
bug ticket at the Ipopt mailing list describing exactly you problem (and 
what OS and compilers you are using), and attach the Ipopt/config.log file 
(in the Ipopt subdirectory!) and the files necessary to reproduce this 



On Fri, 15 May 2009, Ashutosh Mahajan wrote:

> 3.6.1 is also available. the release didnt seem to be announced on the mailing
> list. the issue might have been fixed there.
> ashutosh
> On Fri, 15 May 2009, Johan ?kesson wrote:
>>    Hi!
>>    I just compiled Ipopt 3.6.0 (with MA27) on an OpenSuse 11 system.
>>    Compilation went went without problems and I can run the tests (make
>>    tests).
>>    When I run the freshly compiled Ipopt executable with AMPL I get an
>>    error with some models, for example
>>   > ampl DoubleIntegrator.run
>>    Ipopt 3.5.4: max_iter = 10000
>>    error running /home/jakesson/Ipopt/Ipopt-3.6.0/build/bin/ipopt:
>>            termination code 11
>>    <BREAK>
>>    The problem I try to solve is simple and solves easily on other
>>    platforms. A strange thing is that some models solve just fine with
>>    the very same Ipopt executable that gives termination code 11 in the
>>    example above.
>>    I have also tried to compile Ipopt 3.5.4 on the very same machine but
>>    experience the exact same results.
>>    Best
>>    /Johan
>> _______________________________________________
>> Ipopt mailing list
>> Ipopt at list.coin-or.org
>> http://list.coin-or.org/mailman/listinfo/ipopt
> --
> regards
> Ashutosh Mahajan
> http://coral.ie.lehigh.edu/~asm4
> _______________________________________________
> Ipopt mailing list
> Ipopt at list.coin-or.org
> http://list.coin-or.org/mailman/listinfo/ipopt

More information about the Ipopt mailing list