[Coin-ipopt] ./configure checking size of int

Uwe Kuessel U.Kuessel at irt.rwth-aachen.de
Thu Oct 5 09:20:40 EDT 2006

Dear Mr. Waechter, dear IPOPT support team,
i tried to install IPOPT the way you describe it in 'Introduction to
IPOPT'. I am using cygwin for a windows system. i downloaded the third
party code and started with ./configure. After some time the following
error occurs in the cygwin prompt:
checking for int *... yes
checking size of int *... 4
configure: error: Unknown length of int *
configure: error: /bin/sh './configure' failed for Ipopt
I do not understand this error. The plattform is AMD 64 bit processor
with a 32 bit windows 2000. It seems like it recognize the 32 bit system
but then jumps in the wrong case. I tried hardcoding the size of int to
4 and then it runs succesfully, but i am unsure if this is good way of
doing it. In addition i have the make  3.81 problem with multiple
patterns. i tried to downgrade my make command by using the cygwin setup
but a lower version is not supported . can i get it somewhere and
install it manually? attached are the config.log files. it may help
screening for my mistake.
thanks a lot
uwe kuessel

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 6502 bytes
Desc: not available
Url : http://list.coin-or.org/pipermail/ipopt/attachments/20061005/b0984abe/attachment.obj 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config1.log
Type: application/octet-stream
Size: 50401 bytes
Desc: not available
Url : http://list.coin-or.org/pipermail/ipopt/attachments/20061005/b0984abe/attachment-0001.obj 

More information about the Coin-ipopt mailing list