[Ipopt] linear solvers with internal support for 64-bit integers

Sean Hardesty sean.hardesty at gmail.com
Fri Jun 15 07:25:10 EDT 2018

 The crash doesn't occur with the newer HSL solvers. Here’s what I’ve found
so far - I would be glad to hear if I’ve gotten anything wrong, and suggest
that a summary such as the one below might be useful if included with the
documentation about the solvers. It is hard to do large-scale optimization
with the 32-bit limit.

Internal support for 64-bit integers in the 32-bit interface:
MA27: no
MA57: no, but at some point Mathworks used to use a modified version that
did support 64-bit integers before switching to UMFPACK. I don't know
whether this version is available somewhere.
MUMPS: no as of 4.10.0 (the version downloaded by Ipopt), yes as of 5.1.0.
I haven't tried to use 5.1.0+ with Ipopt yet.
WSMP: no (it failed in the same place as MA27, MA57, and MUMPS 4.10.0)
MA86: yes (it worked where MA27, MA57, MUMPS 4.10.0, and WSMP failed)
MA97: yes (presumably the same as MA86, though I haven't tried it yet)
PARDISO: ? (I've had difficulty linking against MKL on my system, so I
haven't tried it)

    Sean Hardesty

On Wed, Jun 13, 2018 at 3:22 PM Sean Hardesty <sean.hardesty at gmail.com>

> I am experiencing a crash during Ipopt's call to the linear solver, using
> packages provided with Ubuntu 16.04 (there are packages for Ipopt and
> MUMPS). The same thing happens with source builds of MUMPS, MA27, and MA57.
> For my problem, the total number of variables / constraints and non-zero
> entries are all on the order of 10^5 to 10^6, so 32-bit integers are
> perfectly adequate for specifying the constraint Jacobian in triplet
> format. What I believe is happening is that factoring the system creates so
> much fill-in that the solver will fail unless it internally uses 64-bit
> integers for indexing.
> Are any of the solvers supported by Ipopt free of this issue? I am aware
> from previous comments by Jonathan Hogg that the more modern HSL solvers
> use 64-bit integers, but are there any problems with the Ipopt interface?
> MUMPS gives vague instructions for compiling with 64-bit integers:
> http://mumps.enseeiht.fr/index.php?page=faq#3.3
> For HSL or MUMPS, do I have to hack metis 4 to use 64-bit integers, like
> in this post?
> http://matrixprogramming.rudnyi.ru/2008/05/metis-64bit/
>     Thanks,
>     Sean Hardesty
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://list.coin-or.org/pipermail/ipopt/attachments/20180615/51eb7bd2/attachment.html>

More information about the Ipopt mailing list