[Ipopt] Problem of installing Coin-HSL with IPOPT

Hongkai Dai daih at mit.edu
Wed Apr 18 12:53:10 EDT 2012


I am trying to install HSL solvers for IPOPT-3.10 on my 64 bit 
Ubuntu-11.04 machine. I can install IPOPT with solvers ma27 and ma57 
separately, by following the instructions on this page 
https://projects.coin-or.org/BuildTools/ticket/69. This works well with 
my MATLAB and AMPL interface. But since I work on some large problems, I 
then I tried to install solvers like ma77, ma 86, etc, I download 
coinhsl-2012.02.14 from this page http://www.hsl.rl.ac.uk/ipopt/, name 
it as 'coinhsl' in the directory ThirdParty/HSL/, and then do the 
installation process as
../configure --enable-static CC=gcc-4.3 CXX=g++-4.3 F77=gfortran-4.3 
ADD_CXXFLAGS="-fPIC -fexceptions" ADD_CFLAGS="-fPIC -fexceptions" 
ADD_FFLAGS="-fPIC -fexceptions"


Namely, I compile IPOPT with HSL together. But when I run 'make test', 
an error occurs, the error message is as below:

Exception of type: OPTION_INVALID in file 
"../../../../Ipopt/src/Algorithm/IpAlgBuilder.cpp" at line 308:
  Exception message: Selected linear solver MA27 not available.
Tried to obtain MA27 from shared library "libhsl.so", but the following 
error occured:
libhsl.so: cannot open shared object file: No such file or directory

EXIT: Invalid option encountered.

Namely, there is not a file named libhsl.so

Then I tried to install coinhsl before installing IPOPT, I go through 
the 'configure', 'make' and 'sudo make install' process for coinhsl. 
Then I install IPOPT, add 'LD_LIBRARY_PATH=/usr/local/lib/' in the 
configure command for IPOPT, but when I make IPOPT, it throws an error


    use hsl_ma77_double
Fatal Error: Can't open module file 'hsl_ma77_double.mod' for reading at 
(1): No such file or directory

Is there any way to solve this problem? If I cannot install the whole 
package of HSL solvers, how to install solvers like ma77 and ma86 

Thanks a lot for your kind help!


More information about the Ipopt mailing list