[Ipopt] Using ipopt with PARDISO

Renata Silva renatadiasilva at gmail.com
Mon May 24 14:29:28 EDT 2010

Dear all,

I used to test ipopt (version 3.5.5) with PARDISO some time ago with
the CUTEr-SIF interface and, after some problems at the beginning, I
manage to run everything well.

Now I want to update my ipopt results and I have downloaded the last
ipopt version (3.8.1). Again, I am finding some problems when I try to
compile ipopt with pardiso [with ma57 and ma27 everything works fine].
I tried to read again the mailing list messages that I sent and
received when I first have some problems with ipopt/pardiso but I
couldn't solve my problem...

Here is what I got:

%../configure --with-pardiso="-qsmp=omp


checking whether -lblas has BLAS... yes
checking whether LAPACK is already available with BLAS library... no
checking whether -llapack has LAPACK... no
configure: WARNING: Compiling code without LAPACK.  Certain options
(e.g., quasi-Newton) will not work.
checking whether METIS is available... no
configure: Checking for Harwell subroutine library
checking whether user-supplied Pardiso library
-lpardiso -fopenmp" works... configure: error: Pardiso library
-lpardiso -fopenmp does not seem to work
configure: error: /bin/sh '../../Ipopt/configure' failed for Ipopt

In the late mailing messages, someone told me that I should use an
optimized BLAS to run PARDISO, so, after downloading GoToBLAS, I did
the following:

%../configure  --with-blas="-L$HOME/PARDISO/PARDISO-4.0.0 -lgoto2"


checking whether user supplied
BLASLIB="-L/users/extras/renata/PARDISO/PARDISO-4.0.0 -lgoto2"
works... no
configure: error: user supplied BLAS library
"-L/users/extras/renata/PARDISO/PARDISO-4.0.0 -lgoto2" does not work
configure: error: /bin/sh '../../Ipopt/configure' failed for Ipopt

I also tried to run sdipo and got this:


Using source file /users/extras/renata/CUTEr_upd/mastsif/ALSOTAME.SIF

 Problem name: ALSOTAME

 Double precision version will be formed.

 The objective function uses        1 nonlinear group

 There  is        1 nonlinear equality constraint

 There are        2 variables bounded from below and above

Exception of type: OPTION_INVALID in file
"../../../../Ipopt/src/Algorithm/IpAlgBuilder.cpp" at line 327:
 Exception message: Selected linear solver Pardiso not available.
Tried to obtain Pardiso from shared library "libpardiso.so", but the
following error occured:
undefined symbol: GOMP_loop_dynamic_next

EXIT: Invalid option encountered.


Again, looking at the old mailing list messages, I see that I need to
link the -lgomp library, so I tried:


% ../configure CFLAGS="-lgomp -fopenmp -O3 -lpthread" FFLAGS="-lgomp
-fopenmp -O3 -lpthread -fno-second-underscore"
--with-blas="-L$HOME/PARDISO/PARDISO-4.0.0 -lgoto2"


(and similar stuff) and got the same results.

I am running out of ideias now... can you see what am I doing wrong or
can you suggest me something?

Many thanks,

Renata Silva, PhD
Auxiliary Investigator, Molecular Systems Biology Group
Centre for Neuroscience and Cell Biology
Chemistry Department, Office G.35 - University of Coimbra
3004-535 Coimbra, Portugal
Phone: +351-918927181 Fax: +351-239827703

More information about the Ipopt mailing list